Cannot install DataAccessGuidancePackageSetup.msi

Dec 15, 2007 at 7:31 AM
I did a few things before I tried installing the DataAccessGuidancePackageSetup.msi.
1. I disabled UAC (just to be sure)
2. created .cmd files for installing de GAX and GAT
3. ran as Administrator after installing first the GuidanceAutomationExtensions and then the GuidanceAutomationToolkit
4 created a .cmd file for installing the DataAccessGuidancePackageSetup
5. tried to install but it says the extesions isnt installed (what the hell?)

Did I do something wrong?

Trying to install on Windows Vista Home Premium with Visual Studio 2008.
Dec 18, 2007 at 1:29 PM
I have the same problem ... may be still no support for VS 2008!
Jan 16, 2008 at 3:26 PM
You did nothing wrong, current dropped release from MS doesn't support to install package with VS 2008. If i wasn't wrong, you installed GAX July 2007 CTP for VS 2008 and msi could not find those extension.
You need to open source code and change setup package in VS 2008 environment, change launching condition to reflect path of VS 2008 and compile new msi file.
- Click DataAccess Guidance Package Setup project.
- Click Launching condition.
- Click RUNTIME on the left and change RegKey in property to SOFTWARE\Microsoft\VisualStudio\9.0\InstalledProducts\RecipeManagerPackage
(8.0 is for VS 2005 & 9.0 for VS 2008)

Hope this help.
Duy Doan.
May 29, 2008 at 1:31 AM
Did this work for any one? It did not work for us.
May 29, 2008 at 5:27 AM
Did not work for me either, I am using Entity Framework now but before that I wrote my own O/R mapper. No Design time experience on me private one tho.